Experiences with the easycap DC60 audio and video capture adapter on Linux

This Blog is dedicated to all owners of the STK1160 chip based EasyCAP (or identical) devices, who want to use it under Linux.

Activating audio for the STK1160 device: read the this post

German speaking users: read my article on ubuntuusers.de

The EasyCAP DC60 and its clones are cheap little USB analogue capturing devices which can be used for viewing and recording video under Linux from different sources like VHS tape recorders, satellitereceivers, camcorders ...


This page is outdated because the easycapdriver is already part of the kernel release and will be replaced by the better stk1160 driver in the 3.7 kernel (spring 2013 releases of all major distros). 
A rework of this page is pending. 

Easycap driver related problems
1. Basic checklist
2. Driver limitations
3. I can see a picture but i do not hear any sound
4. Driver shutdown because of bad signal coming from source (condition green)
5. Driver shutdown because of copy protectet VHS tape (condition blue)
6. Mplayer / mencoder framedropping
7. ffmpeg delayed audio

Syntek driver related problems
1. Syntekdriver does not support audio

Easycap 1: Basic checklist 
- Check if all cables are connected properly
- Always connect the Easycap directly (with or without cable) to the USB 2.0 plug on your PC, never use an USB-HUB or USB 1.1
- If you use a SCART adapter be sure it supports input and output (SCART adapters coming with cameras or wii console ... only support input.
- Run dmesg on the commandline and check if the device is registered by the driver
- Did you ran chmod a+rw /dev/easy* as root
(not necessary anymore if the driver created udev rules -  since driver version 0.8.x)
- Do you have all the applicationes installed you want to use:
Mplayer / mencoder; Tvtime; vlc 1.0.2 or later; ffmpeg

Easycap 2: driver limitations
- Driver shuts down on bad signal caused by channel switching or gaps between tape recordings (4)
- Driver shuts down on signal coming from copy protected vhs tapes (5)
- Driver crashes may occur:
If you see many easycap related error messages on dmesg output, plug out and in the device (and ran ./permit.sh again if necessary).

Easycap 3: no sound
- Check all the cables and the mixer settings (are the  audio controls switched on?).
- If the driver is compiled with OSS support, check if you have /dev/dsp on your system and oss support is enabled (Ubuntu doesn't support OSS anymore since 10.10).

- If you use sox (./tvtime.sh requires sox) be sure to have libsox-fmt-oss (ubuntu) installed.
- Sometimes the snd_usb_audio driver which is loaded (but not needed) after plugging in the EasyCAP DC60 conflicts with the easycapdriver.
If there is no /dev/easyoss1 or EasyALSA0 soundcard created after plugging in the device, plug out the device and run as root in the terminal:
rmmod snd_usb_audio
Easycap 4: bad signal
If you have some recordings on VHS tape and the video passes the gap between two films sometimes mplyer/ mencoder gets confused and this causes severe audio delay or even driver shutdown.
dmesg reports condition green
The same behavior i see when i do channel switching on my analog sattelite receiver
(This does not occur when you use tvtime or vlc for viewing)
Workaround: Avoid passing recording gaps or channel switching while encoding with mencoder
I do not know by now if ffmpeg can cope with that

Easycap 5: vhs copy protection
There is a workaround for driver shutdown caused by copy protected vhs tapes
(dmesg reports condition blue)
Some lines of the drivers sourcecode have to be commented out.
German manual on ubuntuusers.de
An english version of this manual will be added.

Easycap 6: framedropping
I suppose that framedropping is a driver related problem.
It maybe solved in further kernel releases

Easycap 7: ffmpeg a/v delay
On my try with ffmpeg audio was constantly delayed ~600 ms (10 minute recording)
Audio delay can be easily corrected with avidemux
Vlc has a menu option for adjusting a/v synchronisation while playback

Syntekdriver 1: audio
Audio via USB is not supported by the syntekdriver
Plug in audio source on line in/ mic and select /dev/dsp or your ALSA soundcard as audio device in the recording application.